$re = '/([HDP]\d+)/m';
$str = 'H1
H21
D1
D5
P1
P12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);