# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)@(?!gmail)\w+\.com"
test_str = ("# 配對電子郵件\n\n"
"# 題目說明區塊\n"
"請幫我抓出@(小老鼠)前面的帳戶名稱,而且我不要 gmail 的。\n\n"
"#欲測試資料集\n\n"
"foobar@gmail.com\n"
"NoOneCareMe@gamil.com\n"
"SaveTheWorld@hotmail.com\n"
"zzzGroup@yahoo.com\n"
"eagle1963@gmail.com\n"
"maythefourthwithyiu@starwars.com\n\n"
"# 應配對結果(亮色區塊)\n"
"NoOneCareMe@gamil.com\n"
"SaveTheWorld@hotmail.com\n"
"zzzGroup@yahoo.com\n"
"maythefourthwithyiu@starwars.com\n\n"
"# (選項)寫上註解,好好說明你怎麼想的\n"
"首先將 @ 之前的文字都抓起來,所以放上(),因為不想顧及裡面的文字是什麼,所以很懶惰的使用 .*,步驟多了點但是我不在意XD,因為不想要 gmail 所以我再任意文字 \\w+ 前面判斷寫上不是 gmail,最後放上 \\.com來玩成此次配對,希望你可以幫我減少更多 step(步驟),來提高這個規則的效率。\n\n"
"# (選項)將你的 Regex 註解起來,使用 Extended Formating\n"
"/ # Start of Regex\n"
" ( # Group and Capturing follwoing\n"
" .* # Match any form zero-to-many\n"
" ) # End of group\n\n"
" @ # Match @\n\n"
" ( # Group and Capturing follwoing\n"
" ?! # Negative lookahead\n"
" gmail # Match Gmail\n"
" ) # End of group\n\n"
" \\w+ # Match any character from one-to-many\n"
" \\. # Match .(dot)\n"
" com # Match com\n"
"/ # End of Regex")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.