re = /(?P<street_address>.*(?:Lane|Street|Boulevard|Crescent|Place|Road|Highway|Avenue|Drive|Circuit|Parade|Telopea|Nicklin Way|Terrace|Square|Court|Close|Endeavour Way|Esplanade|East|The Centreway|Mall|Quay|Gateway|Low Way|Point|Rd|Morinda|Way|Ave|St|South Steyne|Broadway|HQ|Expressway|Street|Castlereagh|Meadow Way|Track|Kulkyne Way|Narabang Way|Bank)),? (?P<subrub>[A-Za-z ]+),? (?P<state>[A-Z]+),? (?P<postcode>\d+)/m
str = '139 McKinnon Road, PINELANDS, NT, 829
108 East Point Road, Fannie Bay, NT, 820
3-11 Hamilton Street, Townsville City, QLD, 4810
40 17 Geranium Street, THE GARDENS, NT, 820
1, 3, 5 Demeter Street & 12 Hermes Avenue ROUSE HILL NSW 2155
Lot 9 Island Point Road, ST GEORGES BASIN, NSW, 2540
31 Stephen Street SOUTH TOOWOOMBA QLD 4350
316 Sturt Street and 511 Flinders Street, Townsville City, QLD, 4810'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end