package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b"@#\b`)
var str = `foo"@#bar {}qux`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}