$re = '/^(.*?)\.(?=.*\.)/';
$str = 'www.google.com
google.com
m.facebook.com
www.facebook.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);