#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.(\w+)$"
Local $sString = "1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION" & @CRLF & _
"1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34" & @CRLF & _
"1231231223123131_myFile.tar.gz2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")