re = /^[0-9]{1,2}\/[a-zA-Z]-[0-9]\/[A-Z]+\/([0-9.]+\/)?[0-9]+$/m
str = '11/A-9/XI/2015
12/A-9/XII/2.99/2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end