$re = '/(?<!{){\s*([^{}]*?(?:{{[^{}]+}}[^{}]*?)*)\s*}(?!})/m';
$str = 'identifier{ {{var1}} rest of the {{var2}} {{var3}} content{{something var related}}fdfd } outer content identifier{ {{var2}} another content} identifier{content with no vars }
aaaaaa{ test {{aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa}} } {{{test}}} {test} {{test}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);