$re = '/f04(.*?)(?=z|$)/m';
$str = 'f04abcdefz
f04123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);