$re = '/^((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}$/m';
$str = '123.34.5.67';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);