package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\.\S`)
var str = `.
.
. z
.z
.z z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}