$re = '/\S*www\S*/i';
$str = 'www.senya.ru This www.google.com is the http://www.facebook.com website that https://www.amazon.com make me awesome ruwww';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);