#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Send: (N\d+\s+)?(G0|G1|G2|G3)).*|(Recv: ok)"
Local $sString = "Send: N15316 G2 X132.005 Y144.699 I2.530 J2.266 E1967.48230*80" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N15317 G2 X130.872 Y146.440 I8.090 J6.504 E1967.55146*83" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N15318 G3 X128.033 Y150.765 I-83.048 J-51.420 E1967.72359*80" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N15319 G2 X126.450 Y152.896 I19.401 J16.065 E1967.81191*88" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N15320 G3 X123.581 Y158.450 I-52.577 J-23.641 E1968.01996*86" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3830 G1 F1800 X137.124 Y134.295 E1247.73559*2" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3831 G0 F7200 X137.525 Y134.131*112" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3832 G1 F1800 X173.8 Y170.406 E1249.44186*15" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3833 G0 F7200 X173.957 Y169.997*119" & @CRLF & _
"Recv: == T:209.96 /210.00 == B:60.21 /60.00 @:79 B@:127" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3834 G1 F1800 X137.95 Y133.991 E1251.13549*53" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3835 G0 F7200 X138.404 Y133.878*122" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3836 G1 F1800 X174.132 Y169.606 E1252.81603*7" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3837 G0 F7200 X174.242 Y169.151*121" & @CRLF & _
"Recv: == T:209.73 /210.00 == B:60.66 /60.00 @:85 B@:0" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3838 G1 F1800 X138.857 Y133.766 E1254.48043*2" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3839 G0 F7200 X139.311 Y133.654*116" & @CRLF & _
"Recv: == T:209.77 /210.00 == B:60.69 /60.00 @:84 B@:0" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3840 G1 F1800 X174.354 Y168.697 E1256.12874*13" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3841 G0 F7200 X174.465 Y168.242*123" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3842 G1 F1800 X139.775 Y133.553 E1257.76043*11" & @CRLF & _
"Recv: ok" & @CRLF & _
"Send: N3843 G0 F7200 X140.258 Y133.469*119" & @CRLF & _
"Recv: == T:209.92 /210.00 == B:60.65 /60.00 @:79 B@:0" & @CRLF & _
"Recv: ok" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")