const regex = /(?P<event_message>A user account was unlocked\.)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:\s+(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+Target Account:\s+Security ID:(?P<target_security_id>.*?)\s+Account Name:\s+(?P<target_account_name>.*?)\s+Account Domain:\s+(?P<target_account_domain>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<event_message>A user account was unlocked\\.)\\s+Subject:\\s+Security ID:\\s+(?P<subject_security_id>.*?)\\s+Account Name:\\s+(?P<subject_account_name>.*?)\\s+Account Domain:\\s+(?P<subject_account_domain>.*?)\\s+Logon ID:\\s+(?P<subject_logon_id>.*?)\\s+Target Account:\\s+Security ID:(?P<target_security_id>.*?)\\s+Account Name:\\s+(?P<target_account_name>.*?)\\s+Account Domain:\\s+(?P<target_account_domain>.*)', 'g')
const str = `A user account was unlocked. Subject: Security ID: S-1-5-21-173871781-544419543-443003237-500 Account Name: Administrator Account Domain: AV Logon ID: 0x1E3AD Target Account: Security ID: S-1-5-21-173871781-544419543-443003237-1111 Account Name: test Account Domain: AV`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}