using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!name\(|\[)(?<!city\(|\[)(?<!number\(|\[)([""'])[^\)|^\]]+?(?<!\\)\1";
string input = @"(""h"") [""hi""] {""hi""}
a(""hI"")
j(""hi"")
j('hi')
name(""hi"")
name('hi')
n(""hi"")
city('hi')
number('hi')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}