re = /.*\b((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))/m
str = 'abc 195.4.205.1 fgh
abc 4.195.4.205.1 fgh
abc 4.195.4.205.1.99 fgh
abc 4.195.4.205.1.999 fgh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end