re = /^([A-Za-z]{1}[A-Za-z\d_]*\.)*[A-Za-z][A-Za-z\d_]*$/
str = 'Com.facbook.Ka1nama_foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end