$re = '/[A-Z]+.*\./m';
$str = 'PODER JUDICIÁRIO
TRIBUNAL DE JUSTIçA DO ESTADO DE SãO PAULO
13ª CâMARA DE DIREITO CRIMINAL
AGRAVO DE EXECUçãO PENAL Nº 000000000000 - VOTO Nº 0000 2
VOTO Nº 00000
AGRAVO DE EXECUçãO PENAL Nº 0000000000000000000
AGRAVANTE: MINISTéRIO PúBLICO DO ESTADO DE SãO PAULO
AGRAVADA: NAME
AGRAVO DE EXECUÇÃO PENAL EXECUçãO CRIMINAL PLEITO DE MANUTENçãO DO CARáTER HEDIONDO DO CRIME DE TRáFICO PRIVILEGIADO, A FIM DE MODIFICAR OS CáLCULOS NOVO ENTENDIMENTO DO C. STF EXTERNADO NO JULGAMENTO DO HC Nº 118.533/MS, NO SENTIDO DE AFASTAR A NATUREZA HEDIONDA DO TRáFICO PRIVILEGIADO DE DROGAS DECISãO DO JUíZO EM CONSONâNCIA COM O ENTENDIMENTO ESPECíFICO DO PLENáRIO DO C. STF, QUE Há DE PREVALECER AGRAVO NãO PROVIDO.
CUIDA-SE DE AGRAVO DE EXECUçãO PENAL INTERPOSTO PELO M IN IS T ÉR IO P Ú BLIC O D O E ST A DO D E S Ã O P A ULO CONTRA DECISãO PROFERIDA PELO JUíZO DO DEECRIM DA 6ª RAJ (COMARCA DE RIBEIRãO PRETO), QUE INDEFERIU PEDIDO DE RETIFICAçã';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);