$re = '/(?!C7[789])[CD]\d\d(?:\.\d\d?)?/m';
$str = 'I want to accept D77, D78, D79 but not C77, C78, C79.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);