$re = '/([*+\/-]?)([0-9]+\.?[0-9]*)/m';
$str = '+100*25-30
100*25-30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);