#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n([\d\.]+ ?\w+)"
Local $sString = "" & @CRLF & _
"3.6.10" & @CRLF & _
"POLLUTION DEGREE 4" & @CRLF & _
"continuous conductivity occurs due to conductive dust, rain or other wet conditions" & @CRLF & _
"3.6.11" & @CRLF & _
"CLEARANCE" & @CRLF & _
"shortest distance in air between two conductive parts" & @CRLF & _
"3.6.12" & @CRLF & _
"CREEPAGE DISTANCE" & @CRLF & _
"shortest distance along the surface of a solid insulating material between two conductive" & @CRLF & _
"parts" & @CRLF & _
"4 Tests" & @CRLF & _
"4.1 General" & @CRLF & _
"Tests in this standard are TYPE TESTS to be carried out on samples of equipment or parts."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")