$re = '/^.+(?=\/)/m';
$str = '11.1.1.1/32
1.111.11.1/25
111.1.1.1/21
1.1.111.1/30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);