re = /^02\/(?:[01]\d|2\d)\/(?:19|20)(?:0[048]|[13579][26]|[2468][048])|(?:0[13578]|10|12)\/(?:[0-2]\d|3[01])\/(?:19|20)\d{2}|(?:0[469]|11)\/(?:[0-2]\d|30)\/(?:19|20)\d{2}|02\/(?:[0-1]\d|2[0-8])\/(?:19|20)\d{2}$/m
str = '02/02/1904
02/12/2008
02/29/2012
02/29/2013
06/31/2013
01/31/2013
02/02/1916
02/02/2020
02/02/2024
02/02/2036
02/02/1952
02/02/2056
01/01/2201'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end