import re
regex = re.compile(r"(?<!\d)(?=[\d. -]{11}(?!\d))\d{1,}([. -])\d{1,}\1\d{1,}(?!\d)", flags=re.MULTILINE)
test_str = ("222-33-4444\n"
"333.77-8888\n"
"111 77.9998\n"
"111 22 3333\n"
"11-222222-9\n"
"a222-33-4444\n"
"222-33-4444b\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")