$re = '/(?<![-+.\da-zA-Z_])[+-]?(?:\d+(?:\.\d*)?|\.\d+)(?:[eE][+-]?\d+)?\b/m';
$str = '+334.32423e+32
334.32423e+32
-334.32423
-.32423e+32
.5e-33
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);