#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=by\n)\w.+"
Local $sString = "MIT Sample:" & @CRLF & _
"SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER" & @CRLF & _
"by" & @CRLF & _
"Chih-Ping Tso" & @CRLF & _
"B.Tech., Loughborough University of Technology, United Kingdom" & @CRLF & _
"(1968)" & @CRLF & _
"Submitted in Partial Fulfillment of" & @CRLF & _
"the Requirements for the Degree of" & @CRLF & _
"Master of Science" & @CRLF & _
"at the" & @CRLF & _
"Massachusetts Institute of Technology" & @CRLF & _
"August 1970" & @CRLF & _
"Signature of Author" & @CRLF & _
"Department of Nuclear Engineering" & @CRLF & _
"Certified by" & @CRLF & _
"Thesis Supervisor" & @CRLF & _
"Accepted by" & @CRLF & _
"Chairman, Departmental Committee" & @CRLF & _
"Archives on Graduate Students" & @CRLF & _
"MASS. INST. TECH." & @CRLF & _
"SEP 21 1970" & @CRLF & _
"LIBRARIES" & @CRLF & _
"" & @CRLF & _
"----------------------------------------------" & @CRLF & _
"Virginia Tech Sample:" & @CRLF & _
"FORMATTING VARIABLES AND TYPEFACE VARIATIONS" & @CRLF & _
"OF" & @CRLF & _
"DOT-MATRIX PRINT AND THEIR EFFECT" & @CRLF & _
"ON" & @CRLF & _
"READING COMPREHENSION AND READING SPEED" & @CRLF & _
"by" & @CRLF & _
"James A. Holmes" & @CRLF & _
"Dissertation submitted to the Faculty of the" & @CRLF & _
"Virginia Polytechnic Institute and State University" & @CRLF & _
"in partial fulfillment of the requirements for the degree of" & @CRLF & _
"DOCTOR OF EDUCATION" & @CRLF & _
"in" & @CRLF & _
"Vocational and Technical Education" & @CRLF & _
"March, 1986" & @CRLF & _
"Blacksburg, Virginia"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")