package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$?\d+(?:\.\d{1,50})?$`)
var str = `$1122.334
1122.3
1222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}