re = /^((?!admin|facebook|official)[a-zA-Z])((?!admin|facebook|official|[-_]{2})[-_0-9a-zA-Z])*$/
str = 'name_withfacebook_sdfsdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end