$re = '`^[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-4[a-fA-F0-9]{3}-[8|9|aA|bB][a-fA-F0-9]{3}-[a-fA-F0-9]{12}$`m';
$str = 'c01d7cf6-ec3f-47f0-9556-a5d6e9009a43';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;