import re
regex = re.compile(r"src=(.+?)data-res(.+?)/>")
test_str = ("<video id=\"cb_video_js\" class=\"video-js vjs-default-skin\" width=\"320px\" height=\"240px\" poster=\"http://192.168.0.116/files/thumbs/High.Res.02/1507360901c8cef-1.jpg\" >\n"
"<source src='http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-480.mp4' type=\"video/mp4\" data-res=\"480\" />\n"
"<source src='http://192.168.0.116/files/videos/High.Res.02/1507360901c8cef-720.mp4' type=\"video/mp4\" data-res=\"720\" />\n"
"<p class=\"vjs-no-js\">To view this video please enable JavaScript, and consider upgrading to a web browser that <a href=\"http://videojs.com/html5-video-support/\" target=\"_blank\">supports HTML5 video</a></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")