import Foundation
let pattern = #"\b[A-Z]{2}\d\d(?:(?: ?[A-Z\d]{4}){2,6} ?[A-Z\d]{3}|( ?[A-Z\d]{4}){3,7}(?: ?[A-Z\d]{1,2})?)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
NL64ABNC0417164300
NL64 ABNC 0417 164
NL64 ABNC 0417 1643
NL64 ABNC 0417 1643 0
NL64 ABNC 0417 1643 012
NL64 ABNC 0417 1643 0123
NL64 ABNC 0417 1643 0123 0
NL64 ABNC 0417 1643 0123 0123 0123 0123 01
This is a customer iban DE89 3704 0044 0532 0130 00 from somewhere
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)