$re = '/.*[19\d]79$/m';
$str = '5071343039063711979';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);