$re = '/(?:\G(?!^)|\[)[^][,]*\K,(?=[^][]*])/m';
$str = '"Hello", "Goodbye", ["Yes", "No", "Maybe], "Indeed", ["Why", "What"]';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;