package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\d+([^.]+)\.`)
var str = `aaaa01b.site.com
bbbb01ccc.site.com
cccc02dd.site.com
dd03eeee.site.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}