#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<Date>\d{2}\/\d{2}\/\d{2}) (?<Time>\d{4}) +(?<Terminal>A\d{3}) +(?<Enquirer>C[A-Z0-9]+)"
Local $sString = "START TERMINAL USER ENQUIRER TERMINAL IP" & @CRLF & _
"" & @CRLF & _
"========================================================================================================================" & @CRLF & _
"" & @CRLF & _
"29/05/17 1227 A999 CA75849 8875849 OCBA NCPS RBC/12/1960" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" SEARCH REF NAME : DOE/JOHN PAGE CODE = " & @CRLF & _
"" & @CRLF & _
" DATE OF BIRTH : / /1988" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"========================================================================================================================" & @CRLF & _
"29/05/17 1424 A999 CA75849 8875849 OCBA NCPS RBC/60/2111 " & @CRLF & _
"" & @CRLF & _
" SEARCH REF NAME : SMITH/SIMON/PETER CHAPTER CODE = " & @CRLF & _
"" & @CRLF & _
" DATE OF BIRTH : / /1967" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"========================================================================================================================"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")