re = /(\w* ){1,3}keyword( \w*){1,3}/
str = ' $str = \'word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10\';
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end