import re
regex = re.compile(r"\b(\w+)\b(?=.*\b\1)", flags=re.MULTILINE)
test_str = "GEIGERPK,GIORDAAS,KOUBAPL,PASICAN,PERRENDN,guest_confluence,BIOLLUFE,BUETTNMC,BURKHAMS,DELUCALA,FAEML,GACHNAAS,GAEHWITI,GUINNAHE,JELINETS,KURZENRF,LANFRAMN,MEIERMO,MIESCHAS,PAULUA,ROHREREH,SCHMIDAS,SHAFIKTK,STURZETS,TANASKSA,THALMABE,ZUANMA,freyms,ramseych,FEUCHTML,POURRAFE,BONNAUOR,SCHIERSN,BRANDTRD,CIARLAMO,DALMASJN,DIEZIPK,FALOHUBL,FERRARSE,NIETLIML,SCHWARDL,BARNERFK,BARRASJS,BRUNOME,FLETCHDN,FUJISENS,HESHMAJD,JORDANJL,LIMAMKM,MATTHEPL,REGIDOCS,SHEPHEJE,STEVANVA,WILSONRS,yann,SARCEYOR,AKKERMRR,CHAUFFPE,GUISANPI,HEINZEFR,MEIERKS,MODERSBL,PERRINOR,RUBISN,STUCKIJS,WIESNEJG,BEXVT,BUCZAKWH,FARINEMC,FOUILLGE,HEUTSCDL,MORONVAE,PESICNA,PETRERN,STEINKGD,VARSHNCA,ELBAZAN,JEANNEJE,KERKHOKN,LUDERGL,MAIOLOSO,PEREIRDN,ROUXPE,SCHWARTS,SPRINGJS,WEYFZ,COURTOYN,FOURNIXR,HEERMASL,KOEPPECE,MARTINEE,PIASERJN,PRINTZAA,TRETTIRN,WILLWEWR,BERTHEYK,HOCHSTDL,HOWGRAIT,KUNTZSN,BREMPEML,andreas,benoitf,benoitg,christophe,damien,fabien,louis,olivier,richard,teiva,wojciech,xavierb,xavierh,ALATURVJ,CANHAMMX,CHAILLSE,LEHNERRE,PRADELJN,ROCHATIN,ROUSSEJE,SEILERPP,BRAVOAO,HUERLIRE,RANAWAPI,ZABELWH,DAEMSDK,FISCHERN,STRASSSL,VOSERDL,BRUNML,MEYERSN,BEVILLGY,DAMATAEO,NICOLEJN,VERNGL,BOSONNLN,JOERGEUH,RADEMARD,REHWINTS,bachmafs,ARISZRS,FREYER,JOSTMN,PREVEAVT,RONALDRN,ZBINDEAE,BOMMEPA,GURTNEAX,MAIOLOYO,MARTIPP,MENGPK,OYETANBA,PORTMATS,POTTCS,SIEBERBR,ZIMMERCO,daehleas,eibeckml,lehmanri,IMFELDKL,JONESAE,KAESERMM,KNOPFKN,ROGLHR,TOBLERUS,WINKLEJN,GENOTAPL,BOPPEGE,BRISSAEE,DEVILLNS,BARZILDD,BORELHE,CAMENZML,COLLETAD,DEVINCNS,DRIESSMO,JAUNERRT,SCHLATPP,SZEMROTS,VANINIDL,BOTEZYS,ERNSTRR,FERNANBT,GUERSEHE,BICKOSMK,BOULESFN,CHAMBODN,FLUEKIPR,MHIRIWD,SIEGELHK,LANDHEFN,BEDONIYN,CORBOZJE,PEREZJN,SCHMIDMA,TAPPYAN,WEBERJS,collinae,loribx,FRAUENAS,HARSANTA,PARISOLS,REVERTRD,RUIZHEXR,garrigbt,MUELLEML,SEYDOUOR,BAILLIOR,BAKSHIVK,BORERJC,COQUEURY,mike,BISAZFA,CHENTHCN,CHEVALLC,BARRJS,BARTELCH,LAESSETY,CHEVALLC,MENDOZMT,MERKERPR,MICHELRL,MOTSCHPK,QUINTOCE,RUVILLXR,SIEBERMO"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")