$re = '/\d+/mu';
$str = 'Hello 123 world 456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);