re = /(?:{{)(.+?)(?:}})/m
str = '{{ONE}} {{TWO}} {{THREE}} {{FOUR}} {{FIVE}} {{SIX}}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result