import re
regex = re.compile(r"(?:http|https)://(?:.*\.|.*)imdb.com/(?:t|T)itle(?:\?|/)(..\d+)(.+)?", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("http://www.imdb.com/Title/tt2618986\n"
"http://www.google.com/tt2618986\n"
"https://www.imdb.com/Title/tt2618986\n"
"http://www.imdb.com/title/tt1979376/?ref_=nv_sr_1?ref_=nv_sr_1")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")