import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\d:\\d\\d";
final String string = "Connection 1\n"
+ "Server message: 2022-10-15 23:56:07:028\n"
+ "Message number: 0, Severity 10, State 1, Line 42\n"
+ "Procedure 'psp_dba_maint_4'\n"
+ "Message String: Successfulyl finished running psp_dba_maint_4";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}