import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Name=\")(Show_Type\"|Licensing_Window_End\"|Display_As_New\")(\\s+Value=\"[A-Za-z0-9-:\\s]+\")([\\/>\\s]+)(.*)$";
final String string = "App_Data App=\"MOD\" Name=\"Genre\" Value=\"Series\"/><App_Data App=\"MOD\" \n"
+ "Name=\"Show_Type\" Value=\"Series\"/><App_Data App=\"MOD\" Name=\"Billing_ID\" \n"
+ "Value=\"10092\"/><App_Data App=\"MOD\" Name=\"Licensing_Window_Start\" \n"
+ "Value=\"2019-05-07 00:00:00\"/><App_Data App=\"MOD\" \n"
+ "Name=\"Licensing_Window_End\" Value=\"2019-05-13 23:59:59\"/><App_Data \n"
+ "App=\"MOD\" Name=\"Preview_Period\" Value=\"0\"/><App_Data App=\"MOD\" \n"
+ "Name=\"Display_As_New\" Value=\"4\"/><App_Data App=\"MOD\" \n"
+ "Name=\"Display_As_Last_Chance\" Value=\"7\"/><App_Data App=\"MOD\" \n"
+ "Name=\"Provider_QA_Contact\" Value=\"NBC Universal\"/><App_Data App=\"MOD\" \n"
+ "Name=\"Suggested_Price\" Value=\"0.00\"/><App_Data App=\"MOD\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}