$re = '/\w+(?:\S+\w+)*/m';
$str = 'My test, one. two ASP.net 030-333-12345 end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);