$re = '/\w+|{{((?>(?:(?!(?:{{|}})).)++|(?R))*+)}}/m';
$str = 'aaa
{{bbb}}
aaa {{ bb }}
aa {{ bbb {{ c }} }}
a{a}{{ b{b}b {{ c }} }} ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);