$re = '/^([1-9]{1,2}){1}(\.[0-9]{1,2})?$/';
$str = '67';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);