package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w\.{1}\w\.{1}\w`)
var str = `a.b.c
a..b.c `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}