re = /([^\|]*\|){2}[^\|]*/m
str = 'aaaaaaaaa aaa|bb bbbbb|cccc ccccccc|ddd ddddddd|aaa aaa aaaaa|zzz zzz zzzzzzz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end