$re = '/^\d([\s-]+\d){5,6}$/m';
$str = '1-2-3-4-5-6-7
1 2 3 4 5 6 7
1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);