use strict;
my $str = 'foobar';
my $regex = qr/(?<=foo)/mp;
my $subst = '123';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";