$re = '/[1]{0,1}[A-Z0-9]{2}[\s ||-]{0,2}[A-Z0-9]{7}[\s ||-]{0,2}\K[A-Z]{3}\b/m';
$str = 'the quote number is A1-A123123PAD with AB-1231231-PAD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);